#989 TAM: pre analysis activation took more than 6 hours and half (crazy)


  • Rejected

    , last edited by Jarvis

    Reproduction steps:

    1.- Install KTS2020.

    2.- Update signatures.

    3.- Disabled App + Drv Verif. and rebooted the system.

    4.- Activated TAM via button [Enable] (NOT VIA THE SCAN OF ALL SYSTEM APPLICATIONS), and the pre-analysis started.

    Actual result:

    The pre-activation analysis is extremely slow and took more than 6 hours and half, I'm getting this issue since the last 2 or 3 K2020 beta builds, but not with previous.

    During this analysis my system becomes unusable AT ALL! can't open many applications, others running get freezes, I even can't open Windows Task Manager to check the performance usage.

    During the analysis I also got a dump, but this is not the issue I'm reporting in this post, because I know other tester has already reported it.

    I have Windows 10 Windows Search service disabled, also Superfetch disabled (because I use SSD drives), don't know if TAM pre-activation analysis uses those system services.

    Expected Result:

    A 2~3 hours long (as maximum) TAM pre-activation analysis while I can work normally with my system, as before, in previous 2020 builds and versions K2018 & k2019.

    Attached FULL TRACES + 1 dump during TAM pre-activation collected for near 7 hours -> more than 20GB of compressed data...

    System Settings

    Operating system: Win 10, x64

    System: AMD Athlon II X3 450 @ 3'20Gh, 8GB RAM DDR3, AMD Radeon HD 5670, SSD Samsung pro 850 256GB

    Product: KTS

    Product Version: 20.0.0.+

    Language: en-US

    Product Logs: https://cloud.qainfo.ru/s/EnP24d1EnnREhIc

  • @harlan4096, hello! Is the problem regular reproducing? And if so, could you take a new traces and system dump (guide) at the time of the freezing and slow apps analysing?
  • The issues is only reproduced during the pre-activation analysis, once is finished and TAM is enabled, the system is pretty stable, I mean, TAM remains running and not generating any dump or slowdown 🙂

  • @harlan4096, thanks for the answer! In this case, everything basically works normally. And this topic I will have to close
  • TAM fast pre-activation analysis almost 7 hours to finish and during that analysis the system is almost unusable? I don't think this is a normal working, this pre activation analysis was not working like this previously undecided

  • I have just tried TAM fast enabling (fast pre-analysis -> just clicking in Enable button) with this new build KTS2020 b993... and I got shocked! THE PRE ANALYSIS WAS EXTREMELY FAST! I even could work with the system and it took about 30 minutes as maximum!!! when in previous build the same TOOK NEAR 7 HOURS AND IT WAS IMPOSSIBLE TO WORK WITH THE SYSTEM!

    Great work! surprisedlaughing



Looks like your connection to Beta Testing was lost, please wait while we try to reconnect.