#450 Error27300 when install klhk driver. Error code: -2147024319

  • Rejected


    Same problem reproduced with latest build: RC

    System Settings

    Operating system: Win 10, x64

    System: whatever

    Product: KIS

    Product Version:

    Language: en-US

    Product Logs: https://cloud.qainfo.ru/s/V64MGHfLgV3KdEa

  • I can still reproduce this problem with secure boot enabled. Same error code.

    Can you give more Detailed explanation about the issue?

    As far as I can tell, it is a big problem and stable reporduce using any of my devices.


    logs from new installer.

  • there was also an installation issue with error code 27300 and a secure boot in UEFI is also enabled on the PC


  • Duplicate
  • your are luckly

    I can not install the product use any method

  • , last edited by Helios_07

    Real System:

    Windows 10 64-bit, Version 1809

    KIS de app + drv verifier enabled

    Also got Error 27300 when i tried to install KIS the first time, after another reboot KIS installed normaly.

    KIS setup logs+ screenshot of error: https://cloud.qainfo.ru/s/d9NOW1IXo15HnaE

  • Hello

    Similar driver installation fail can be reproduce using latest build and an entirely different device.

    with secure boot function enabled, product installation always ended up with same error.

    windows10 RS5 17763.55 x64

    kts20.0.0.607 en-us

    Device: MSI GE60 2OC with secure boot enabled

    Firstly, when I report this problem, I thought there may be conflicts between my thinkpad X240s uefi firmware

    but when I try to install product in another device, the problem still reporiduced.

    so I assume that: AVP can not be installed on any device with secure boot enabled.

    I uploaded GSI with installation logs in it, report was generated right after installation failed.

    also I uploaded screenshots about the error code(which is same as two months ago) and my uefi settings.



    Dear KL

    I beleive it is vital that you investigate this problem ASAP

    During these days, I found some topics in business product section of kaspersky forum, user report they can not install product because of a fatal error,

    which, share same error code.

    you can check this one:


    there is no remains of kl drivers but install still fail

    and here



  • Hello.

    Finally, I found the answer.... It is the secure boot function of my laptop.

    Device is  Thinkpad X240s, with new latest firmware v2.43 from Here

    with secure boot Enabled & UEFI only & CMS support off, Klhk.sys can not be installed.

    After I disabled secure boot, installation finished successfully.

  • , last edited by Jarvis
    the link to new gsi link seems not displayed properly, I direct add it in here https://cloud.qainfo.ru/s/kRrBs42bRcz2ADN
  • , last edited by xzz123

    Sadly report that I still can not intsall the latest build, build 454.

    This time, it is the OS that can indeed install build 418 (see here) but than product failed to load. Now I completely lost the opportunity to join the beta test.

    Here is gsi6 report generated from the problematic OS right after the installation failure.


    edit: Before the installation, I even use the removal tool to try unintall avp 19.. Also search registry for avp related and klhk, nothing found.

  • @jarvis


    I did other test,

    I successfully installed 2019 version on the exact same problematic machine. And it was indeed fucntioning normally.

    But than I uninstalled 2019-reboot-install 2020, still got same error code.tongue-out

  • @xzz123, Thank you. Passed new logs to the developers; waiting for an answer.
    Now no other data is needed
  • I again format my drive and clean installed OS, using iso from MSDN.

    still got same error and error code.

    Do you need any other data for investigation? Or is it worth I switch another OS build? 


    new gsi6 report, with installation logs in it.

Looks like your connection to Beta Testing was lost, please wait while we try to reconnect.