#450 Error27300 when install klhk driver. Error code: -2147024319

  • Rejected

    , last edited by Jarvis

    Reproduction steps:

    Install KIS2020.0.0.418 en-us on win10

    Actual result:

    Install failed

    Expected Result:

    Installation is success, product loaded normally

    OS: Windows10 Enterprise 2016LTSB 14393.2248 x64

    Product Build: KIS2020.0.0.418 en-us

    This OS is just newly installed, with few third party software.

    but I can not install avp, I have tried twice. Got same error code.


    GSI6, install logs, error screenshot


    System Settings

    Operating system: Win 10, x64

    System: whatever

    Product: KIS

    Product Version:

    Language: en-US

    Product Logs: https://cloud.qainfo.ru/s/V64MGHfLgV3KdEa

  • @xzz123 bad, that we didn't provide you info much more earlier. 

  • @dmitriy-pisarets

    So that is the reason.....wow, it worrys me for nearly half a year

    the good news is that we finally get a happy ending. Better than never getting an answer.

    You may close the case.smile

  • @xzz123, i got answer from developers: our drivers are not signed now. When 2020 will be released, secure boot will not crash our installer. You can try install 19 version and install it with secure boot. It'll work. 

  • @xzz123 thank you.

  • I am going to get a new laptop, will not hold those old devices for long.

    Please, investigate the problem, before I can still offer you logs and data.

  • @dmitriy-pisarets

    here are new installation logs and GSI6 reprot with windows event logs included.


    Device: Thinkpad X240s with latest BIOS & secure boot enabled & CSM disabled

    OS: windows10 2016LTSB 14393.2670 x64

    OS language: Simplified Chinese

    The problem has long history, and it is highly likely to be reproduced on some of those old devices. 

    with old 4th generation CPU, legacy default boot option. After you turn to secure boot and uefi, product install will fail.

  • @dmitriy-pisarets

    I just disabled secure boot and the installation was successfull.-----Just in oder to check another bug,

    I will reproduce this one next day, it is very late in my here.

  • @xzz123 can you add new installer traces, please? I'll reopen bug

  • Hello

    Same problem reproduced with latest build: RC

  • I can still reproduce this problem with secure boot enabled. Same error code.

    Can you give more Detailed explanation about the issue?

    As far as I can tell, it is a big problem and stable reporduce using any of my devices.


    logs from new installer.

  • there was also an installation issue with error code 27300 and a secure boot in UEFI is also enabled on the PC


  • Duplicate
  • your are luckly

    I can not install the product use any method

  • , last edited by Helios_07

    Real System:

    Windows 10 64-bit, Version 1809

    KIS de app + drv verifier enabled

    Also got Error 27300 when i tried to install KIS the first time, after another reboot KIS installed normaly.

    KIS setup logs+ screenshot of error: https://cloud.qainfo.ru/s/d9NOW1IXo15HnaE

  • Hello

    Similar driver installation fail can be reproduce using latest build and an entirely different device.

    with secure boot function enabled, product installation always ended up with same error.

    windows10 RS5 17763.55 x64

    kts20.0.0.607 en-us

    Device: MSI GE60 2OC with secure boot enabled

    Firstly, when I report this problem, I thought there may be conflicts between my thinkpad X240s uefi firmware

    but when I try to install product in another device, the problem still reporiduced.

    so I assume that: AVP can not be installed on any device with secure boot enabled.

    I uploaded GSI with installation logs in it, report was generated right after installation failed.

    also I uploaded screenshots about the error code(which is same as two months ago) and my uefi settings.



    Dear KL

    I beleive it is vital that you investigate this problem ASAP

    During these days, I found some topics in business product section of kaspersky forum, user report they can not install product because of a fatal error,

    which, share same error code.

    you can check this one:


    there is no remains of kl drivers but install still fail

    and here



  • Hello.

    Finally, I found the answer.... It is the secure boot function of my laptop.

    Device is  Thinkpad X240s, with new latest firmware v2.43 from Here

    with secure boot Enabled & UEFI only & CMS support off, Klhk.sys can not be installed.

    After I disabled secure boot, installation finished successfully.

  • , last edited by Jarvis
    the link to new gsi link seems not displayed properly, I direct add it in here https://cloud.qainfo.ru/s/kRrBs42bRcz2ADN
  • , last edited by xzz123

    Sadly report that I still can not intsall the latest build, build 454.

    This time, it is the OS that can indeed install build 418 (see here) but than product failed to load. Now I completely lost the opportunity to join the beta test.

    Here is gsi6 report generated from the problematic OS right after the installation failure.


    edit: Before the installation, I even use the removal tool to try unintall avp 19.. Also search registry for avp related and klhk, nothing found.

  • @jarvis


    I did other test,

    I successfully installed 2019 version on the exact same problematic machine. And it was indeed fucntioning normally.

    But than I uninstalled 2019-reboot-install 2020, still got same error code.tongue-out

Looks like your connection to Beta Testing was lost, please wait while we try to reconnect.