#450 Error27300 when install klhk driver. Error code: -2147024319

  • Rejected


    Finally, I found the answer.... It is the secure boot function of my laptop.

    Device is  Thinkpad X240s, with new latest firmware v2.43 from Here

    with secure boot Enabled & UEFI only & CMS support off, Klhk.sys can not be installed.

    After I disabled secure boot, installation finished successfully.

    System Settings

    Operating system: Win 10, x64

    System: whatever

    Product: KIS

    Product Version:

    Language: en-US

    Product Logs: https://cloud.qainfo.ru/s/V64MGHfLgV3KdEa

  • Hello

    Similar driver installation fail can be reproduce using latest build and an entirely different device.

    with secure boot function enabled, product installation always ended up with same error.

    windows10 RS5 17763.55 x64

    kts20.0.0.607 en-us

    Device: MSI GE60 2OC with secure boot enabled

    Firstly, when I report this problem, I thought there may be conflicts between my thinkpad X240s uefi firmware

    but when I try to install product in another device, the problem still reporiduced.

    so I assume that: AVP can not be installed on any device with secure boot enabled.

    I uploaded GSI with installation logs in it, report was generated right after installation failed.

    also I uploaded screenshots about the error code(which is same as two months ago) and my uefi settings.



    Dear KL

    I beleive it is vital that you investigate this problem ASAP

    During these days, I found some topics in business product section of kaspersky forum, user report they can not install product because of a fatal error,

    which, share same error code.

    you can check this one:


    there is no remains of kl drivers but install still fail

    and here



  • , last edited by Helios_07

    Real System:

    Windows 10 64-bit, Version 1809

    KIS de app + drv verifier enabled

    Also got Error 27300 when i tried to install KIS the first time, after another reboot KIS installed normaly.

    KIS setup logs+ screenshot of error: https://cloud.qainfo.ru/s/d9NOW1IXo15HnaE

  • your are luckly

    I can not install the product use any method

  • Duplicate
  • there was also an installation issue with error code 27300 and a secure boot in UEFI is also enabled on the PC


  • I can still reproduce this problem with secure boot enabled. Same error code.

    Can you give more Detailed explanation about the issue?

    As far as I can tell, it is a big problem and stable reporduce using any of my devices.


    logs from new installer.

  • Hello

    Same problem reproduced with latest build: RC

  • @xzz123 can you add new installer traces, please? I'll reopen bug

  • @dmitriy-pisarets

    I just disabled secure boot and the installation was successfull.-----Just in oder to check another bug,

    I will reproduce this one next day, it is very late in my here.

  • @dmitriy-pisarets

    here are new installation logs and GSI6 reprot with windows event logs included.


    Device: Thinkpad X240s with latest BIOS & secure boot enabled & CSM disabled

    OS: windows10 2016LTSB 14393.2670 x64

    OS language: Simplified Chinese

    The problem has long history, and it is highly likely to be reproduced on some of those old devices. 

    with old 4th generation CPU, legacy default boot option. After you turn to secure boot and uefi, product install will fail.

  • I am going to get a new laptop, will not hold those old devices for long.

    Please, investigate the problem, before I can still offer you logs and data.

  • @xzz123 thank you.

  • @xzz123, i got answer from developers: our drivers are not signed now. When 2020 will be released, secure boot will not crash our installer. You can try install 19 version and install it with secure boot. It'll work. 

  • @dmitriy-pisarets

    So that is the reason.....wow, it worrys me for nearly half a year

    the good news is that we finally get a happy ending. Better than never getting an answer.

    You may close the case.smile

  • @xzz123 bad, that we didn't provide you info much more earlier. 

Looks like your connection to Beta Testing was lost, please wait while we try to reconnect.