#3964 Не пропускает защищенное соединение с почтовыми серверами yandex.ru


  • Rejected

    , last edited by Jarvis

    Шаги воспроизведения:

    Установлен Microsoft Outlook 2013, настроен ящик через POP. Plus 21.5.10.335.

    В настройках включена проверка защищенных соединений по запросу компонентов защиты. В случае возникновения ошибки выбран вариант "Спрашивать"

    Актуальный результат:

    Не доставляются письма в почтовую программу.

    Ожидаемый результат:

    Письма будут доставляться.

    System Settings

    Operating system: Win 10, x64

    System: Intel Core i3, ASUS MB, 8Gb DDR4

    Product: PLUS

    Product Version: 21.5.6.243

    Language: ru-RU

    Product Logs: https://cloud.qainfo.ru/s/fiS6EF1LsT5EcAQ

  • @unclwish, добрый день! Вы можете попробовать воспроизвести и записать видео?  ("Никаких ошибок не видно, запросите видео пожалуйста, чтобы было ясно в чём именно проблема.")

    В ваших трейсах три запроса к почтовому серверу:

    1) запрос на неверный порт

    2) соединение закрыто клиентом, сразу же после обращения к серверу

    3) обычная сессия с корректным обращением и установкой связи клиент - сервер.

  • Еще момент - ранее работало, до 21.5.10.335? Или настройка почты производилась после установки продукта? Работает ли при выключении продукта?

  • Всё работало, до автоматического обновления прошлого билда на новый.

    Почта настроена давно, да и непосредственно после обновления доставка почты в Аутлук работала корректно. Только через пару-тройка часов начались проблемы.

    Уверен, что после переустановки начисто всё заработает. Но почему именно автоматическое обновление вызывает такое, не знаю... Пока не переустанавливал, просто пока отключил защиту защищенных соединений.

    Записывать видео не вижу смысла. При включенной проверке Аутлук просто выдаёт ошибку при попытке подключиться с серверу pop.yandex.ru или pop3.yandex.ru. Он просто не получает письма с ящика. Через браузер всё работает.

    Отключаю защиту защищенных соединений - и аутлук начинает получать почту как ни в чем не бывало.

  • @unclwish said in Не пропускает защищенное соединение с почтовыми серверами yandex\.ru:

    Записывать видео не вижу смысла. 

    Для анализа необходимо  видео(чтобы было видно часы) и синхронные с ним продуктовые трассировки.

    также нужны логи будут логи с версии, где проблема не воспроизводится.

    В любом другом случае, к сожалению, анализ не возможен

  • , last edited by UnclWish

    И всё-таки я не понимаю, что даст видео. Пока включена защита защищенных соединений, письма не приходят вообще. До тех пор, пока не отключишь эту защиту.

    Видимо, что Plus просто не даёт установить подключение по портам, которые запрашивает Аутлук.

    Боюсь, что теперь до окончания праздников у меня вряд ли будет возможность осуществить запись видео одновременно с трейсами...

    Если получится, то сделаю, хоть и не понимаю, зачем.

    P.S. Кстати, в аутлук подключен еще и другой ящик по IMAP, там всё приходит. Такое чувство, что проблема именно в серверах yandex. Или 2-й ящик не использует защищенное соединение... там сервер kursknet.ru

    Обидно то, что если снесу и поставлю заново, то всё будет работать, уверен на 200%, было уже такое. Проблема возникает именно после автоматического обновления....

  • @unclwish said in Не пропускает защищенное соединение с почтовыми серверами yandex\.ru:

    И всё-таки я не понимаю, что даст видео.

    Видео нужно с открытыми часами, с отображением секунд (прошу прощения, что сразу не указал). Разработчику это нужно, чтобы соотнести наши логи с поведением почтового клиента. Случай не простой, так как в трейсах никаких явных блокировок нет и все выглядит корректным. 

  • @dmitriy-pisarets

    я понял. Сделаю, 3-го числа выложу. Подскажите, чем оптимальнее всего записать видео?

  • @unclwish, я обычной записью роликов пользуюсь из Windows 10 Game Bar'а.  Win+G по-умолчанию.  Можете и OBS использовать, точных требований к записи видео у нас нет. 

    Тут главное, чтобы был открыт почтовый клиент и часы windows одновременно, 

  • Cannot Reproduce
  • Воспроизводится только при установке поверх предыдущей версии. При новой установке всё работает, как надо.



Looks like your connection to Beta Testing was lost, please wait while we try to reconnect.