#3810 AVPUI: high CPU load and memory consumption


  • Rejected

    , last edited by Jarvis

    Reproduction steps: Open Reports or Manage Applications window, maximize to full screen, scroll or move/hover mouse. This is on Windows 11, but looks similar to my former issue report of KES Beta running on W10.

    Actual result: High CPU load by AVPUI.EXE (one CPU core maxed, another core loaded 50%).

    Expected Result: Low CPU load by AVPUI.EXE.

    Extra note: The initial scan window right after installation also causes AVPUI.EXE to load one CPU core to about 50% (or about half of AVP.EXE, which only seems to use a single-core in this scan). This seems quite high for doing little more than animating a single progress bar.

    Furthermore memory consumption of AVPUI.EXE seems excessively high during a normal "Full Scan". Even worse, when the UI window is closed then memory consumption initially drops, but only after some time and then it builds up again even while the window is still closed.

    (4.16% = 1 CPU core maxed out of 24 logical cores)

    UI load while moving mouse in Manage Applications window: https://imgur.com/xw8STmD

    UI load during initial (post-setup) scan: https://imgur.com/FJ5KCLA

    UI memory during Scan All with window open: https://imgur.com/UArvsgp

    UI memory during Scan all with window closed (keeps going up and down): https://imgur.com/E8nSfov

    System Settings

    Operating system: Win 10, x64

    System: 5900X, MSI X570, 16 gb, M.2 SSD

    Product: PLUS

    Product Version: 21.5.3.140

    Language: en-US

  • Hello! for such reports we need xperf traces: - our bat files and steps are here - https://box.kaspersky.com/d/b005d35ddec14eb4b31f/ - xperf should be installed with *Windows ADK* - also you should turn off debugging mechanism (you can click "beta" button at the top left corner) - our traces should be disabled too
  • , last edited by Timur Born

    You already got traces and animated GIFs for the same issues during the KES beta. I got no feedback for the traces I sent in, but especially the high load and lag of the maximized reports window should be easily reproducable.

  • Sorry for long reaction time. I had contacted with colleagues, and they said there is no need for second report. KES and Kaspersky use one code "core", so problem will be fixed once for all apps.


Looks like your connection to Beta Testing was lost, please wait while we try to reconnect.