#3749 Excluded domains (domain.tld) are still decrypted


  • Accepted

    , last edited by Jarvis

    Reproduction steps: Add domain.tld (askmrrobot.com) to "Trusted addresses" list to exempt it from being decrypted.

    Actual result: Kaspersky script is still added to the web-site. The only way to make this work is to  add "www." or "*." to the domain exception. Since the "Trusted addresses" dialog specifically lists "example.com" as legitimate format I assume this to be a bug.

    Curiously I also reported this to support for KIS where the same happens and just got told that this was "by design"?! To make things worse with KIS you cannot use the "*." workaround (invalid format error), so for KES we at least have some way to exclude a whole domain.

    Expected Result: Whole domain, including all sub-domains, should be excluded from decryption.

    These are screenshot using KIS, but the same applies to KES:

    askmrrobot.com

    www.askmrrobot.com

    System Settings

    Operating system: Win 10, x64

    System: 5900X, MSI X570, 16 gb, M.2 SSD

    Product: KES

    Product Version: 11.7.0.658

    Language: en-US

  • 1)Diffenence between usin example.com and mask, like * or www. is "by design".2)Is the plagin installed in browser in this test?

  • 1) Does "example.com" without mask do anything then?

    2) The browser plugin was not installed.

  • @timur-born1)it's put to exclusion site with address example.com.  I create bug about incorrect promt.



Looks like your connection to Beta Testing was lost, please wait while we try to reconnect.