#3084 Suggestion: I hope the test team can test whether there will be errors in upgrading from the previous MR to the new MR.


  • Rejected

    , last edited by Jarvis

    I have heard that some users will have application errors during cross-version and cross-MR updates. I think this is a very rare event, but it seems that this is not the case. In our investigation, we found that most applications Users with abnormalities often have problems after upgrading from the old MR to the new MR through automatic update. Reinstallation seems to be able to solve the problem, but in their "Programs and Features" list, the original MR version cannot be uninstalled normally. It can only be displayed there all the time.

    I installed Kaspersky’s MR1 ​​version on another computer. It was updated to the MR2 version through automatic updates, but a fatal error occurred. The application cannot be updated normally and cannot be used normally. The right-click menu has about Kaspersky All parts of SKY are invalid, and it seems to have reached a very serious level. I checked the application list and saw that there are two Kaspersky application versions (one is the original MR1, and the other is the MR2 installed by automatic upgrade) , I reinstalled the MR2 version, these fatal errors no longer occur, but in the application list, the original MR1 version cannot be deleted normally, and the message cannot be deleted. It needs to be restarted and tried, but this prompt still appears after the restart.

    Due to the latest update method, the large version is advanced much faster than before. The original application may be updated once a year, but now it will be performed once in a few months. If this update method has a very high probability of error, then I hope the test team can conduct a test investigation, because if a fatal error occurs, the user may not find it in time. At this time, the program does not have any prompts, but it is already in a state of almost unable to work normally.

    System Settings

    Operating system: Win 10, x64

    System: Intel Core i7 10700k, Samsung 970 EVO Plus

    Product: KTS

    Product Version: 21.3.6.277

    Language: zh-CN

    Product Logs: no need

  • Hello! we have test-group, who test only upgrades. They have pack of auto-teste which every day run updates from different old versions. If some errors occur while update - they should be send to support service
  • @jarvis

    I don't trust this update team because they made major mistakes. In the 2020 version, users in China cannot update normally, they can only rely on alternate update sources (https://downloads.upd.kaspersky.com). This has caused problems in the updates in China within half a year. I reported this problem to technical support on the first day of product release, and it took six months to fix it.

    I hope this suggestion can be submitted because the frequency of problems is very high.

  • Your suggestion admitted. But it doesn't need a bug to be created in our tracker


Looks like your connection to Beta Testing was lost, please wait while we try to reconnect.